2.1 ติดตั้ง LoadBalance RB750GL แบบ 4 PPPOE to 1LAN

วิธีการติดตั้ง และปรับแต่งอุปกรณ์ Mikrotik
ให้รองรับการทำงานที่หลากหลายความต้องการ
การติดตั้ง HotSpot Server, การติดตั้ว Load Balanced ฯลฯ

2.1 ติดตั้ง LoadBalance RB750GL แบบ 4 PPPOE to 1LAN

โพสต์โดย jadeson เมื่อ พฤหัสฯ. 12 ม.ค. 2012 6:04 am

รูปภาพ 2.1 ติดตั้ง MikroTik RB750GL แบบ 4 PPPOE to 1 LAN - Load Balanced 4 เส้น
บทความสำหรับ: ผู้ที่มีความรู้เกี่ยวกับระบบเครือข่ายในระดับเบื้องต้นถึงปานกลาง (v1.1)
โดย วิทวัส โฉมประเสริฐ, ศุภสิทธิ์ ศิริพานิชกร, เจตน์สันติ์ ยาวิลาศ

คำถาม

ต้องการทำ LoadBalance รวมเน็ตจำนวน 4 เส้น โดยเซ็ตโมเด็มเป็นแบบบริดจ์ทั้งหมด แล้วให้ MikroTik รุ่น RB750GL เป็นสั่งการเชื่อมต่อ PPPOE ต้องทำอย่างไร?

คำตอบ



รูปภาพ



วิธีการตั้งค่า LoadBalance RB750GL แบบ 4 PPPOE to 1LAN

  1. ดาวน์โหลด Winbox แล้วเสียบสาย LAN ขา Ether5 ของ MikroTik
    เข้าโปรแกรม Winbox แล้วคลิกเลือก mac address MikroTik ที่ broadcast เจอ แล้วกด Connect

    รูปภาพ


  2. จะมี mac address ของขา LAN (RB750GL) ที่เราเชื่อมต่ออยู่ ขึ้นมา กด Connect เพื่อเชื่อมต่อ

    รูปภาพ


  3. Winbox กำลังเชื่อมต่อเข้าไปยัง RB750GL

    รูปภาพ


  4. ปกติแล้ว MikroTik แทบทุกรุ่นจะมี config default ให้ แต่เราจะไม่ใช่ครับ กด Remove Configuration ได้เลย

    รูปภาพ


  5. RB750GL จะทำการ Remove config default ออก แล้วจะ reboot ตัวเอง ถ้าเกิด message เด้งขึ้นมา ก็ไม่ต้องตกใจน่ะครับ

    รูปภาพ


  6. สร้าง Connection PPPOE ผ่านเมนู PPP

    รูปภาพ


  7. ที่เมนู PPP กดปุ่ม + เพื่อสร้าง PPPOE โดยเลือก PPPOE Client

    รูปภาพ


  8. สร้าง pppoe-out1 (3BB-7b)

    รูปภาพรูปภาพ


  9. สร้าง pppoe-out2 (TRUE-7b)

    รูปภาพรูปภาพ


  10. สร้าง pppoe-out3 (สมมุติ TOT-7b) ผมมีเน็ตทดลองอยู่ 2 เส้น สร้างเส้นที่ 3 ขึ้นมา เพื่อเขียนโค้ดรองรับผู้ใช้ที่ใช้งานให้ครอบคลุม 4 เส้นครับ

    รูปภาพรูปภาพ


  11. สร้าง pppoe-out4 (สมมุติ adsl-7b) ผมมีเน็ตทดลองอยู่ 2 เส้น สร้างเส้นที่ 4 ขึ้นมา เพื่อเขียนโค้ดรองรับผู้ใช้ที่ใช้งานให้ครอบคลุม 4 เส้นครับ

    รูปภาพรูปภาพ


  12. ตรวจสอบการสร้าง PPPOE ทั้ง 4 เส้นผ่านเมนู PPP > PPP

    รูปภาพ


  13. เนื่องด้วยถ้าทำในรูปแบบ Interface นั้นจะต้อง Capture หน้าจอเยอะมาก ผมจึงขอเปลี่ยนไปใช้วิธี code ผ่าน Terminal น่ะครับ
    เข้าเมนู New Terminal > Terminal

    รูปภาพ


  14. คัดลอก code

    โค้ด: เลือกทั้งหมด
    #|/ip address
    /ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment="default configuration"

    #|/ip firewall mangle
    /ip firewall mangle add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=ether1_conn
    /ip firewall mangle add chain=input in-interface=pppoe-out2 action=mark-connection new-connection-mark=ether2_conn
    /ip firewall mangle add chain=input in-interface= pppoe-out3 action=mark-connection new-connection-mark=ether3_conn
    /ip firewall mangle add chain=input in-interface= pppoe-out4 action=mark-connection new-connection-mark=ether4_conn

    /ip firewall mangle add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
    /ip firewall mangle add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2
    /ip firewall mangle add chain=output connection-mark=ether3_conn action=mark-routing new-routing-mark=to_ether3
    /ip firewall mangle add chain=output connection-mark=ether4_conn action=mark-routing new-routing-mark=to_ether4

    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:4/2 action=mark-connection new-connection-mark=ether3_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:4/3 action=mark-connection new-connection-mark=ether4_conn passthrough=yes
    /ip firewall mangle add chain=prerouting connection-mark=ether1_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether1
    /ip firewall mangle add chain=prerouting connection-mark=ether2_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether2
    /ip firewall mangle add chain=prerouting connection-mark=ether3_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether3
    /ip firewall mangle add chain=prerouting connection-mark=ether4_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether4


    #|/ip route
    /ip route add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_ether1 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_ether2 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=pppoe-out3 routing-mark=to_ether3 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=pppoe-out4 routing-mark=to_ether4 check-gateway=ping

    /ip route add dst-address=0.0.0.0/0 gateway=pppoe-out1 distance=1 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=pppoe-out2 distance=2 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=pppoe-out3 distance=3 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=pppoe-out4 distance=4 check-gateway=ping

    #|/ip firewall nat
    /ip firewall nat add chain=srcnat out-interface=pppoe-out1 action=masquerade
    /ip firewall nat add chain=srcnat out-interface=pppoe-out2 action=masquerade
    /ip firewall nat add chain=srcnat out-interface=pppoe-out3 action=masquerade
    /ip firewall nat add chain=srcnat out-interface=pppoe-out4 action=masquerade

    #| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
    /ip pool add name=default-dhcp ranges=192.168.0.100-192.168.0.200
    /ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
    /ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1 dns-server=192.168.0.1 comment="default configuration"

    #| DNS
    /ip dns set allow-remote-requests=yes
    /ip dns static add name=router address=192.168.0.1

    #| Now Configure DNS server so users can resolve hostnames,
    #| Ex.cache-size=5000KiB
    #| DNS Google = 8.8.8.8,8.8.4.4
    #| DNS 3BB = 110.164.252.222,110.164.252.223
    /ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000K max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4



    สำหรับกรณีที่ ความเร็ว Internet ไม่เท่ากัน ก็สามารถแก้ไขโค้ดบรรทัดดังนี้ (ตัวอย่าง WAN 1,2,3 ความเร็ว 4Mb และ WAN 4 ความเร็ว 8 Mb)
    (หลักการคือ ในการวน 1 ลูปจะมีกี่ครั้งก็ได้ เพียงพยายามแชร์ Bandwidth ที่จะใช้เท่าๆกัน หรืออาจจะเซตไปบางLink เป็นพิเศษ ตามความต้องการก็ได้ครับ
    - ในตัวอย่าง 1 ลูปมี 5 ครั้ง 4/0 ไปจนถึง 4/4 โดยพยายามเกลี่ย Bandwidth ที่ใช้ให้ออกผ่าน Link ทั้งหมด ให้ใกล้เคียงกัน)

    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/2 action=mark-connection new-connection-mark=ether3_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/3 action=mark-connection new-connection-mark=ether4_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/4 action=mark-connection new-connection-mark=ether4_conn passthrough=yes


    ผมแนะนำให้คัดลอกโค้ดเก็บไว้เป็น Word เพราะถ้าต้องการเปลี่ยน IP หรือเปลี่ยนค่าอื่นๆ เราสามารถใช้ฟังก์ชั่นค้นหาและแทนที่ ได้เลย

    รูปภาพ
    รูปภาพ


  15. คลิกขวา ที่แถบ command บน terminal แล้ว Paste

    รูปภาพ


  16. รูปแสดงตัวอย่างการป้อนโค้ด

    รูปภาพ


  17. หลังจากป้อนโค้ดเสร็จแล้วควรสั่ง Reboot ครั้งหนึ่ง ด้วยคำสั่งบน terminal ดังนี้ system reboot

    รูปภาพ


  18. หลัง RB750GL reboot เสร็จ ก็ connect เชื่อมต่อใหม่อีกครั้ง

    รูปภาพ


  19. ทดสอบโหลดเต็มสปีด
    สังเกตุ pppoe-out1 Rxวิ่ง 6Mbps, pppoe-out2 Rxวิ่ง 7.1Mbps และ ether5 Txวิ่ง 13.5Mbpx

    รูปภาพ


  20. ทดสอบถอดเน็ตแต่ละเส้น โดยไล่ถอด 3BB ก่อน สลับกับ True เพื่อตรวจสอบว่า RB750GL เชื่อมต่อและสลับ Link ใช้อัตโนมัติหรือไม่ ซึ่งผลก็คือ ได้ครับ :D :D
    สังเกตจากกราฟ ที่ pppoe-out1 ถูกถอดออกจะลดหายไป แต่ใน ether5 ยังสามารถโหลดได้อยู่แต่จะได้ ประมาณ 6Mbps กว่าๆ ซึ่งได้มาจาก pppoe-out2
    และเมื่อเชื่อม pppoe-out1 เข้าไปใหม่ ใน ether5 ก็กลับมาโหลดได้เต็มที่ประมาณ13Mbps กว่าๆเหมือนเดิม

    รูปภาพ



  21. TEST SPEED ผ่าน Web Browser (วิ่งรวม 2 เส้นได้ประมาณ 13.12Mbps)

    รูปภาพ



    ปล.

    - โค้ดที่ให้มานี้อาจจะไม่ดีที่สุด แต่ก็สามารถใช้งานได้ดีระดับหนึ่ง
    ผู้อ่านท่านใดมีคำแนะนำ สามารถแนะนำกันได้ครับ จะได้ช่วยกันพัฒนาต่อยอด
    ซึ่งทาง sys2u เราก็จะพยายามหาวิธี ที่จะให้ผู้ใช้ สามารถเซตค่าตัวอุปกรณ์ MikroTik ให้ได้ง่ายกว่านี้ครับ




    ข้อมูลสินค้าแบบมัลติมีเดีย (Multimedia)




    จบบทความ

รายละเอียดการให้บริการจากทีมงาน SYS2U.COM Xpert Zone
แก้ไขล่าสุดโดย jadeson เมื่อ ศุกร์ 07 ก.ย. 2012 8:28 am, แก้ไขแล้ว 1 ครั้ง
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
jadeson
 
โพสต์: 605
ลงทะเบียนเมื่อ: อังคาร 03 ก.พ. 2009 4:50 pm

Re: 2.1 ติดตั้ง LoadBalance RB750GL แบบ 4 PPPOE to 1LAN

โพสต์โดย chayapan เมื่อ อังคาร 03 เม.ย. 2012 4:52 pm

Config รูปแบบนี้รองรับ Failed-Over มั้ยคับ แลัวถ้าจะทำ Protocol Binding ต้องเขียนยังไงคับและวางไว้ส่วนไหน
chayapan
 
โพสต์: 10
ลงทะเบียนเมื่อ: เสาร์ 18 ก.ค. 2009 4:44 pm

Re: 2.1 ติดตั้ง LoadBalance RB750GL แบบ 4 PPPOE to 1LAN

โพสต์โดย sys2u เมื่อ อังคาร 03 เม.ย. 2012 5:05 pm

chayapan เขียน:Config รูปแบบนี้รองรับ Failed-Over มั้ยคับ แลัวถ้าจะทำ Protocol Binding ต้องเขียนยังไงคับและวางไว้ส่วนไหน


  • ไม่แน่ใจว่า Failed-Over จะความหมายเดียวกันหรือไม่นะครับ + ถ้า Failed-Over ในความหมายของทีมงานคือ " ใช้แค่ 1 เส้น ส่วนเส้นที่เหลือไม่ใช้งานเอาเป็นสำรอง Backup Link ไว้ ถ้าในกรณีที่เส้นหลัก down ลงไป ถึงจะสลับการใ้ช้งานไปที่ Backup Link เท่านั้นครับผม " หรือเปล่าครับ ?

  • config อันนี้จะทำ Load Balanced อย่างเดียวครับ คือทำงานไปพร้อมๆ กันทุกเส้นเลยครับผม ถ้าเส้นไหน down ลงไป ตัว Mikrotik ก็จะย้ายการเชื่อมต่อที่ค้างอยู่ไปยัง Link ที่ยังทำงานอยู่ให้อัตโนมัติครับผม :D
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
sys2u
Administrator
 
โพสต์: 4716
ลงทะเบียนเมื่อ: อังคาร 30 ก.ย. 2008 12:35 pm
ที่อยู่: SYS2U.COM Bangkok, Thailand.

Re: 2.1 ติดตั้ง LoadBalance RB750GL แบบ 4 PPPOE to 1LAN

โพสต์โดย ktccww เมื่อ พุธ 05 ก.ย. 2012 5:39 pm

ผมสงสัยนิดนึงครับ

1. สำหรับกรณีที่ ความเร็ว Internet ไม่เท่ากัน ก็สามารถแก้ไขโค้ดบรรทัดดังนี้ (ตัวอย่าง WAN 1,2,3 ความเร็ว 4Mb และ WAN 4 ความเร็ว 8 Mb)

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/2 action=mark-connection new-connection-mark=ether3_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/3 action=mark-connection new-connection-mark=ether4_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/4 action=mark-connection new-connection-mark=ether4_conn passthrough=yes

ตรงที่บอกว่าความเร็วไม่เท่ากัน ให้แก้ไขน่ะครับ

สมมุติว่าผมมี WAN 1,2= 6Mbps WAN3,4 = 7Mbps

ผมต้องใส่ยังไงครับ
ใส่เป็นตัวอย่างให้ดูได้ไหมครับ

2. เปลี่ยน IP จาก 192.168.0.1 เป็น 192.168.1.1 น่ะครับ
ผมต้องแก้ไขตามนี้ถูกไหมครับ

/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment="default configuration"
....
#| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
/ip pool add name=default-dhcp ranges=192.168.1.100-192.168.1.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.1.0/24 gateway=192.168.1.1 dns-server=192.168.1.1 comment="default configuration"

3. เรื่องการ forward port ของตัวนี้น่ะครับ

อ้างจากกระทู้นี้น่ะครับ viewtopic.php?f=53&t=14049

ผมสงสัยว่า ถ้า forward port มันจะเข้ามาได้ทาง ether1 เท่านั้นหรือเปล่าครับ
หรือว่าเราสามารถทำ multiddns ให้ ether1,2,3,4 ได้ด้วยครับ

4. ตัว 750GL สามารถเปิดทิ้งไว้ได้นานขนาดไหนครับ หมายถึงต้องคอยปิดเปิดอุปกรณ์ไหมครับ หรือว่าตัว 750GL สามารถตั้งเวลาให้ restart ตัวเองได้ครับ

5. ตัว 750GL กับ 450GL อันไหนทนกว่ากันครับ

ขอบคุณครับ
ktccww
 
โพสต์: 1
ลงทะเบียนเมื่อ: พุธ 05 ก.ย. 2012 12:11 am

Re: 2.1 ติดตั้ง LoadBalance RB750GL แบบ 4 PPPOE to 1LAN

โพสต์โดย jadeson เมื่อ พุธ 05 ก.ย. 2012 10:24 pm

ktccww เขียน:ผมสงสัยนิดนึงครับ

1. สำหรับกรณีที่ ความเร็ว Internet ไม่เท่ากัน ก็สามารถแก้ไขโค้ดบรรทัดดังนี้ (ตัวอย่าง WAN 1,2,3 ความเร็ว 4Mb และ WAN 4 ความเร็ว 8 Mb)

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/2 action=mark-connection new-connection-mark=ether3_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/3 action=mark-connection new-connection-mark=ether4_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/4 action=mark-connection new-connection-mark=ether4_conn passthrough=yes

ตรงที่บอกว่าความเร็วไม่เท่ากัน ให้แก้ไขน่ะครับ

สมมุติว่าผมมี WAN 1,2= 6Mbps WAN3,4 = 7Mbps

ผมต้องใส่ยังไงครับ
ใส่เป็นตัวอย่างให้ดูได้ไหมครับ


มองเหมือนการวนลูป แล้วเกลี่ยๆให้เท่าๆกันก็ได้ครับ เช่นถ้ามี 4 link แบนวิธเท่าๆกัน ก็เกลี่ยเป็น 1 Link ต่อ 1 ครั้งก็ได้ครับ
แต่ถ้าสมมุติ มี link ใดที่โดดๆมี แบนวิธเยอะๆ ต้องการแชร์เพิ่ม ก็เพิ่มในลูปเป็น 5 ครั้งโดยใส่ link นั้นเพิ่มอีก 1 ครั้ง

โค้ด: เลือกทั้งหมด
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/2 action=mark-connection new-connection-mark=ether3_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/3 action=mark-connection new-connection-mark=ether4_conn passthrough=yes


ktccww เขียน:2. เปลี่ยน IP จาก 192.168.0.1 เป็น 192.168.1.1 น่ะครับ
ผมต้องแก้ไขตามนี้ถูกไหมครับ

/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment="default configuration"
....
#| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
/ip pool add name=default-dhcp ranges=192.168.1.100-192.168.1.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.1.0/24 gateway=192.168.1.1 dns-server=192.168.1.1 comment="default configuration"


เปลี่ยน IP จากวง 192.168.0.1 เป็น 192.168.1.1 ได้เลยครับ

โค้ด: เลือกทั้งหมด
/ip address add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether5 comment="default configuration"
....
#| DHCP server is on switch, with address pool 192.168.1.100-192.168.1.200
/ip pool add name=default-dhcp ranges=192.168.1.100-192.168.1.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.1.0/24 gateway=192.168.1.1 dns-server=192.168.1.1 comment="default configuration"


ktccww เขียน:3. เรื่องการ forward port ของตัวนี้น่ะครับ

อ้างจากกระทู้นี้น่ะครับ viewtopic.php?f=53&t=14049

ผมสงสัยว่า ถ้า forward port มันจะเข้ามาได้ทาง ether1 เท่านั้นหรือเปล่าครับ
หรือว่าเราสามารถทำ multiddns ให้ ether1,2,3,4 ได้ด้วยครับ


สามารถทำได้ครับ แต่ก็ต้องแก้โค้ดเพิ่มเติมอ่ะครับ ลองศึกษาโดยตรงจาก Mikrotik ได้ผ่าน Link นี้ครับ
>> http://wiki.mikrotik.com/wiki/Dynamic_D ... for_dynDNS
** แนะนำให้ดูก่อนน่ะครับว่า script ที่ใช้นั้นเป็น version ที่ตรงกับของเราไหม ปัจจุบันรุ่นใหม่ๆจะเป็น 5.xx ขึ้นไปแล้วครับ

ktccww เขียน:4. ตัว 750GL สามารถเปิดทิ้งไว้ได้นานขนาดไหนครับ หมายถึงต้องคอยปิดเปิดอุปกรณ์ไหมครับ หรือว่าตัว 750GL สามารถตั้งเวลาให้ restart ตัวเองได้ครับ


สามารถเปิดได้ตลอด 24 ชม.ครับ แต่แนะนำให้อยู่ในห้องที่มีอากาศถ่ายเทสะดวก และไม่ร้อนจนเกินไป ถ้ามี UPS จะดีมากครับจะได้ป้องกันกระแสไฟตก ไฟกระชาก

ส่วนเรื่องการตั้งค่า Restart ให้อุปกรณ์ก็สามารถทำได้ครับ เพียงเขียนโค้ดสั่ง restart เพิ่มใน Schedule โดยตั้งเวลาได้ตามที่เรากำหนดได้เลย

ktccww เขียน:5. ตัว 750GL กับ 450GL อันไหนทนกว่ากันครับ


แทบทุกรุ่นของ Mikrotik ที่ออกมานั้น ถือว่าใช้งานได้ทนทานมากครับ อึด ไม่ค่อยมีอาการง้อแง้เลยครับ จะมีก็แต่เราต้องเลือกรุ่นให้ถูกกับการใช้งานครับ อาทิ
750GL เหมาะสำหรับ user ที่ใช้งานพร้อมๆกันไม่เกิน30
450G เหมาะสำหรับ user ที่ใช้งานพร้อมๆกันไม่เกิน50
ส่วนรุ่นอื่นๆ ก็จะมี detail พิเศษแตกต่างกันออกไป เลือกใช้ให้ตรงกับการใช้งานก็ได้ละครับ ส่วนเรื่องการโค้ดคำสั่งต่างๆ เหมือนกันหมดทุกรุ่นครับ

ขอบคุณครับ
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
jadeson
 
โพสต์: 605
ลงทะเบียนเมื่อ: อังคาร 03 ก.พ. 2009 4:50 pm


ย้อนกลับไปยัง วิธีการติดตั้งและปรับแต่งอุปกรณ์ Mikrotik

ผู้ใช้งานขณะนี้

กำลังดูบอร์ดนี้: ไม่มีสมาชิกใหม่ และ บุคคลทั่วไป 2 ท่าน