1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet

วิธีการติดตั้ง และปรับแต่งอุปกรณ์ Mikrotik
ให้รองรับการทำงานที่หลากหลายความต้องการ
การติดตั้ง HotSpot Server, การติดตั้ว Load Balanced ฯลฯ

1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet

โพสต์โดย vit_et07 เมื่อ พฤหัสฯ. 09 ธ.ค. 2010 1:28 pm

รูปภาพ 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet
บทความสำหรับ: ผู้ที่มีความรู้เกี่ยวกับระบบเครือข่ายในระดับเบื้องต้นถึงปานกลาง (v1.1)
โดย วิทวัส โฉมประเสริฐ, ศุภสิทธิ์ ศิริพานิชกร

คำถาม

1.ถ้าต้องการเชื่อมต่อ Internet โดยใช้งานภายในองค์กรที่มีผู้ใช้งาน 50 เครื่องโดยใช้อุปกรณ์ MikroTik RB750G ต้องตั้งค่าอย่างไรบ้าง ?

คำตอบ

อุปกรณ์ Compact Router MikroTik RB750G-BOX ขนาดเล็กสำหรับใช้งานระดับบ้าน และสำนักงานขนาดเล็ก มาพร้อมด้วย 5 กิกะบิทพอร์ท 10/100/1000 Mbps รองรับการทำงานที่หลากหลาย สามารถรองรับการทำงาน Load Balancing, HotSpot Gateway และ VPN Server เหมาะสำหรับสำนักงานขนาดเล็ก (มาพร้อมด้วย MikroTik RouterOS v4, Level4)

ในบทความนี้จะเป็นขั้นตอนการติดตั้ง MikroTik RB750G-BOX โดยเชื่อมต่อกับ INTERNET กับ ISP โดยมี MODEM ที่ตั้งค่าเป็น Bridge ซึ่ง INTERFACE มีดังนี้
PORT LAN 1 = INTERFACE WAN (PPPOE)
PORT LAN 2 = MASTER PORT (DHCP SERVER 192.168.10.40/24)
PORT LAN 3 = MASTER SUB ของ PORT LAN 2

    บทความนี้จะประกอบไปด้วยขั้นตอนในการติดตั้ง ดังนี้ครับ

  1. วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet
  2. การทำ Route Table และ Firewall ในระบบให้ภายในสามารถออกขา WAN และ มี Firewall ควบคุมได้


    รูปภาพ



ดาวน์โหลด - WINBOX


การเชื่อมต่อเข้าไปตัว Miktrotik RB750G ตรวจสอบค่า interface ต่างๆ


  1. เชื่อมต่อคอมพิวเตอร์เข้าช่อง LAN2 ของ Miktrotik RB750G

  2. ตรวจสอบ IP ADDRESS ของคอมพิวเตอร์ที่ได้รับมาโดยค่าจากโรงงานที่อัำพมาจะเป็น IP ADDRESS : 192.168.88.1 /24

    รูปภาพ

  3. เปิดโปรแกรม WINBOX ซึ่งเป็นเหมือนโปรแกรมตั้งค่าตัวอุปกรณ์ Miktrotik RB750G ทั้งหมด

    รูปภาพ

  4. หน้าโปรแกรม WINBOX ดังนี้
    Connect TO : ระบุ IP ADDRESS ของ Miktrotik RB750G หรือ MAC Address ของ Miktrotik RB750G
    Login : ค่าจากโรงงานจะเป็น admin
    Password : ค่าจากโรงงานจะไม่มีรหัส

    Connect

    รูปภาพ

  5. ระบบจะระบุว่้าต้องการตั้งค่า Interface ให้อัตโนมัติหรือไม่ กด OK

    รูปภาพ

  6. เข้าเมนู
    INTERFACES - เป็นเมนูที่ตั้งค่าของ PORT LAN ทั้ง 5 PORT ว่าต้องการใช้งานแบบใด และ ความเร็วของการรับ-ส่ง ข้อมูลของแต่ละ port 10 / 100 /1000
    Ether1 - Gateway เชื่อมต่อกับ MODEM โดยสิทธิ์ของ port นี้ที่ Master port : NONE
    Ether2 - Local - Mastrer แจก DHCP ~ Master port : NONE
    Ether3 - Local - Slave เป็น port ที่ระบุ MASTER port : Ether2 - Local - Master เพื่อให้สามารถใช้งาน port 3 ขยายเพิ่มได้

    รูปภาพ

    รูปภาพ




การสร้าง Connection Internet


  1. การสร้างการเชื่อมต่อ Internet บน Miktrotik RB750G ไปที่เมนู
    PPP -> Interface

    กด + เลือกไปที่ PPPoE Client

    รูปภาพ


    NEW Interface
    General
    Interface : Ether1 - Gateway

    รูปภาพ


    Dial Out
    User : ชื่อผู้ใช้งาน INTERNET
    Password : รหัสใช้งาน INTERNET

    USE PEER DNS : ระบุ DNS ที่ได้รับมาจาก ISP ให้ LOCAL มองเห็น

    รูปภาพ

    รูปภาพ




ผู้ใช้สามารถเปลี่ยน IP บนอุปกรณ์ Miktrotik RB750G ของระบบได้เอง


  1. การเปลี่ยน IP ของ LOCAL ผู้ใช้สามารถเปลี่ยนแปลงได้ไปที่เมนู
    IP -> ADDRESS LIST
    ดับเบิ้ลคลิ้กค่า Default เดิมเพื่อเปลีั่ยนแปลง
    Address : ตั้งค่า IP Address ของ Miktrotik RB750G และ Subnet ใหม่
    ตั้งค่า Network ID
    ตั้งค่า Broadcast ID
    Interface : ระบุ port Ether 2 - Local - Master

    รูปภาพ

  2. หลังจากบันทึการเปลี่ยน IP ~ ของ Miktrotik RB750G เรียบร้อยแล้ว WINBOX จะตัดการเชื่อมต่อไปเพราะ IP Address Miktrotik RB750G เปลี่ยนไปแล้ว

  3. ให้ทำการ FIX IP ใหม่ให้อยู่ในวงเดียวกับ Miktrotik RB750G ที่เปลีั้ยนแปลง

    รูปภาพ

  4. เปิดใช้งาน WINBOX
    ระบุ Connect to : ให้ตรงกับ IP Address Miktrotik RB750G

    รูปภาพ

  5. ตั้งค่าในส่วนของ Network เมื่อเวลาแจก IP ให้ผู้ใช้งานให้ชี้ไปที่ไหนบ้างเวลาใช้งาน INTERNETไปที่เมนู
    IP -> DHCP SERVER
    NETWORK
    เปลี่ยนแปลงจากค่าเดิมให้ Address ระบุ Network ID+subnet , GATEWAY , DNS ชี้ไปที่ IP ของ Miktrotik RB750G

    รูปภาพ

  6. ตั้งค่าการแจก IP Address ไปที่เมนู
    IP -> POOL
    เปลี่ยนแปลงค่าการแจก IP Address จากของเดิม

    รูปภาพ

  7. เปลี่ยน IP Computer ให้รับ IP แบบอัตโนมัติ

    รูปภาพ




การทำ Route Table และ Firewall ในระบบให้ภายในสามารถออกขา WAN และ มี Firewall ควบคุมได้


  1. กระบวนการทำ Route เป็นการระบุว่า Network ID แต่ละวงให้ไปหาปลายทาง Distination ใดเพื่อเป็น Gateway ขาออกในระบบ , NAT เป็นการ NAT ไอพีชุดด้านในให้ออกไปหาไอพีขานอก หรือ ประเภท Port forwarding ,

  2. ตั้งค่า INTERNET ในการ Route+Firewall 1 เส้นดังต่อไปนี้

    เมนู
    IP -> Routes
    Routes
    กด +
    General
    Dst. Address : 0.0.0.0/0
    Gateway : pppoe-out1
    Check Gateway : ping

    รูปภาพ


    เมนู
    IP -> Firewall
    ์NAT กด +
    General
    Chin : srcnat
    Out.Interface : pppoe-out1

    รูปภาพ


    Action
    Action : masquerade - > ถึงตรงนี้จะสามารถออก INTERNET ได้แล้ว

    รูปภาพ


    เมนู
    IP -> Firewall
    Mangle กด+
    General
    Chin : input
    in.Interface : pppoe-out1

    รูปภาพ


    Action
    Action : mark connection
    New Connection Mark : pppoe-out1_conn

    รูปภาพ


    Mangle กด+
    General
    Chin : output
    Connectiom Mark : pppoe-out1_conn

    รูปภาพ


    Action
    Action : mark routing
    New Routing Mark : to_wan1

    รูปภาพ

    เมนู
    IP -> Routes
    Routes
    กด +
    General
    Dst. Address : 0.0.0.0/0
    Gateway : pppoe-out1
    Routing Mark : to_wan1

    รูปภาพ






ข้อมูลสินค้าแบบมัลติมีเดีย (Multimedia)


[youtube][/youtube]




จบบทความ

รายละเอียดการให้บริการจากทีมงาน SYS2U.COM Xpert Zone
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
vit_et07
 
โพสต์: 994
ลงทะเบียนเมื่อ: พุธ 01 ต.ค. 2008 10:30 am

Re: 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet

โพสต์โดย sofhat เมื่อ พฤหัสฯ. 13 มิ.ย. 2013 2:43 pm

ผมใช้โมเด็มแบบของเน็ตเคเบิ้ลใยแก้ว (docsis ของ true) ก้ใช่วิธีนี้ 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet ตั้งค่าเหมือนกันปะคับ

หรือมีอะไรแตกต่างครับ

แล้วค่า ip ของ mikrotik 192.168.88.1 /24

/24 คืออะไรครับ

รูปภาพ

ในรูปนี้ /24 ก้ไม่ขึ้นนะครับ
sofhat
 
โพสต์: 23
ลงทะเบียนเมื่อ: จันทร์ 10 มิ.ย. 2013 7:08 pm

Re: 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet

โพสต์โดย vit_et07 เมื่อ พฤหัสฯ. 13 มิ.ย. 2013 4:17 pm

sofhat เขียน:ผมใช้โมเด็มแบบของเน็ตเคเบิ้ลใยแก้ว (docsis ของ true) ก้ใช่วิธีนี้ 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet ตั้งค่าเหมือนกันปะคับ

หรือมีอะไรแตกต่างครับ

แล้วค่า ip ของ mikrotik 192.168.88.1 /24

/24 คืออะไรครับ

รูปภาพ

ในรูปนี้ /24 ก้ไม่ขึ้นนะครับ



cable ของทรูอาจจะให้ตัว Router ที่เขาแถมมาเป็นตัวแจก ip อยู่แล้วนะครับ การตั้งค่าจะไม่เหมือนกันกับ ADSL ที่ทำ PPOE Client อาจจะต้องทำเป็นแบบ static ip เอาครับ
ถ้าเอาคอมต่อกับ router cable ทรู แล้วได้รับ ip ออก internet ได้ก็แสดงว่า เราต้องมา static ที่ mikrotik ให้เป็นวงเดียวกับ cable แล้วละครับ

2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN - ดูที่ wan 1 อย่างเดียวครับ

ส่วน /24 เป้นความหมายของ Sunet mask จำนวนกี่ bit อย่างนี้จะเป็น 255.255.255.0 นะครับ
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
vit_et07
 
โพสต์: 994
ลงทะเบียนเมื่อ: พุธ 01 ต.ค. 2008 10:30 am

Re: 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet

โพสต์โดย sofhat เมื่อ พฤหัสฯ. 13 มิ.ย. 2013 6:18 pm

able ของทรูอาจจะให้ตัว Router ที่เขาแถมมาเป็นตัวแจก ip อยู่แล้วนะครับ การตั้งค่าจะไม่เหมือนกันกับ ADSL ที่ทำ PPOE Client อาจจะต้องทำเป็นแบบ static ip เอาครับ
ถ้าเอาคอมต่อกับ router cable ทรู แล้วได้รับ ip ออก internet ได้ก็แสดงว่า เราต้องมา static ที่ mikrotik ให้เป็นวงเดียวกับ cable แล้วละครับ


ถ้าเอาคอมต่อแล้วสังเกตอย่างไงครับว่าได้รับ ip จากตัว modem router cable

ผมอ่านเจอคร่าวๆ ถ้าเราไมทำตาม2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN

แต่ต่อเข้า Mikrotik แล้วรับแบบ DHCP Client ไปเลยได้ไหมคับ
sofhat
 
โพสต์: 23
ลงทะเบียนเมื่อ: จันทร์ 10 มิ.ย. 2013 7:08 pm

Re: 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet

โพสต์โดย vit_et07 เมื่อ พฤหัสฯ. 13 มิ.ย. 2013 6:31 pm

sofhat เขียน:
able ของทรูอาจจะให้ตัว Router ที่เขาแถมมาเป็นตัวแจก ip อยู่แล้วนะครับ การตั้งค่าจะไม่เหมือนกันกับ ADSL ที่ทำ PPOE Client อาจจะต้องทำเป็นแบบ static ip เอาครับ
ถ้าเอาคอมต่อกับ router cable ทรู แล้วได้รับ ip ออก internet ได้ก็แสดงว่า เราต้องมา static ที่ mikrotik ให้เป็นวงเดียวกับ cable แล้วละครับ


ถ้าเอาคอมต่อแล้วสังเกตอย่างไงครับว่าได้รับ ip จากตัว modem router cable

ผมอ่านเจอคร่าวๆ ถ้าเราไมทำตาม2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN

แต่ต่อเข้า Mikrotik แล้วรับแบบ DHCP Client ไปเลยได้ไหมคับ





ถ้าเอาคอมต่อแล้วสังเกตอย่างไงครับว่าได้รับ ip จากตัว modem router cable


ตัว Cable ก็เป็น Router นะครับ โดยจะแจก ip มาให้ที่เครื่องคอมของเรา ก็เช็คว่า ip address ที่ได้คืออะไร ใน network ของเครื่อง

รูปภาพ



ผมอ่านเจอคร่าวๆ ถ้าเราไมทำตาม2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN

แต่ต่อเข้า Mikrotik แล้วรับแบบ DHCP Client ไปเลยได้ไหมคับ


ถ้า Router ของเราแจก DHCP มาอยู่แล้วก็ สามารถปลักเข้า ตัว Mikrotik ได้เลยครับเพราะ ตัว อุปกรณ์จะรับ ip optain อยู่แล้ว
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
vit_et07
 
โพสต์: 994
ลงทะเบียนเมื่อ: พุธ 01 ต.ค. 2008 10:30 am

Re: 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet

โพสต์โดย sofhat เมื่อ พฤหัสฯ. 13 มิ.ย. 2013 11:39 pm

:mrgreen: คำถามนะครับ
1. ถ้าผมใช้ true cable routher ซึ่งแจก ip เอง
แล้วผมต้องการทำให้เป็น static ip ตาม2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN โดยสนใจเเค่ wan 1 เสียบเข้า port 1 แล้วเสียบแลนทำ hotspot ที่ port 5 โค้ดที่ผมวางไว้ข้างล่างถูกไหมครับ ถ้าผิดช่วยแก้ไขหน่อยนะครับ
โค้ด: เลือกทั้งหมด
#|/ip address
/ip address add address=192.168.1.2/24 network=192.168.10.0 broadcast=192.168.10.255 interface=ether1
/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment="default configuration"

#|/ip firewall mangle
/ip firewall mangle add chain=input in-interface=ether1 action=mark-connection new-connection-mark=ether1_conn

/ip firewall mangle add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1

/ip firewall mangle add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=ether5

/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=ether1_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether1

#|/ip route
/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping

#|/ip firewall nat
/ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

#| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
/ip pool add name=default-dhcp ranges=192.168.0.100-192.168.0.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1 dns-server=192.168.0.1 comment="default configuration"

#| DNS
/ip dns set allow-remote-requests=yes
/ip dns static add name=router address=192.168.0.1

#| Now Configure DNS server so users can resolve hostnames,
#| Ex.cache-size=5000KiB
#| DNS Google = 8.8.8.8,8.8.4.4
#| DNS 3BB = 110.164.252.222,110.164.252.223
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000K max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4


2. การทำ code แบบนี้ เท่ากับเปลี่ยน ip ของ mikrotik ด้วยใช่ไหมครับ เพราะเรา remove configuration ไป เช่นในกรณีนี้จาก 192.168.88.1 มาเป็น 192.168.0.1
แล้วจาก 2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN router 1; ip 192.168.1.1
ทำไมเราเขียน code เป็น
/ip address add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1
แทนที่จะเขียนเป็น /ip address add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1


3.
/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes

เราต่อ wan เเค่สายเดียว ต้องวนลูปไหมคับ เเล้ว code นี้ต้องเปลี่ยนไหมคับ

4.
#| DNS 3BB = 110.164.252.222,110.164.252.223


อันนี้เกี่ยวกับเครื่อยข่ายไหมครับถ้าเปนทรูต้องเปลี่ยนไหมคับ

5. การทำแบบนี้เราเสียบแลนออกจาก port 2 ของ mikrotik ทำตาม 1.1 วิธีทำ Hotspot บน MikroTik RB750G (1 Internet)ได้ปกติเลยปะครับ

6.
#|/ip address
/ip address add address=192.168.10.2/24 network=192.168.10.0 broadcast=192.168.10.255 interface=ether1
/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment="default configuration"

การกำหนดค่านี้ ip ที่ mikrotik รับมาจาก cable router คืออะไรคับ

7.
#| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
/ip pool add name=default-dhcp ranges=192.168.0.100-192.168.0.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1 dns-server=192.168.0.1 comment="default configuration"


code นี้คือถ้าผมตั้งค่า port 5 ให้เป็น hotspot ตามรูป
รูปภาพ
ผมต้องตั้งให้แจก ip อยู่ระหว่าง 192.168.0.100-192.168.0.200 หรอคับ

ปล ผมเสนอให้ตั้งกระทู้เกี่ยวกับการตั้ง mikrotik เมื่อเชื่อมกับกับ cable modem แบบ static ip นะครับ เพราะการตั้งแบบ DHCP Client แม้จะง่ายกว่าเเต่ทำให้ mikrotik ทำงานหนัก
คนที่ใช้อินเตอร์เน็ตแบบเคเบิ้ลก้มีเยอะขึ้นเช่นกัน
sofhat
 
โพสต์: 23
ลงทะเบียนเมื่อ: จันทร์ 10 มิ.ย. 2013 7:08 pm

Re: 1.0 วิธีติดตั้ง MikroTik RB750G เพื่อเชื่อมต่อ Internet

โพสต์โดย vit_et07 เมื่อ ศุกร์ 14 มิ.ย. 2013 11:29 am

sofhat เขียน::mrgreen: คำถามนะครับ
1. ถ้าผมใช้ true cable routher ซึ่งแจก ip เอง
แล้วผมต้องการทำให้เป็น static ip ตาม2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN โดยสนใจเเค่ wan 1 เสียบเข้า port 1 แล้วเสียบแลนทำ hotspot ที่ port 5 โค้ดที่ผมวางไว้ข้างล่างถูกไหมครับ ถ้าผิดช่วยแก้ไขหน่อยนะครับ
โค้ด: เลือกทั้งหมด
#|/ip address
/ip address add address=192.168.1.2/24 network=192.168.10.0 broadcast=192.168.10.255 interface=ether1
/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment="default configuration"

#|/ip firewall mangle
/ip firewall mangle add chain=input in-interface=ether1 action=mark-connection new-connection-mark=ether1_conn

/ip firewall mangle add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1

/ip firewall mangle add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=ether5

/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=ether1_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether1

#|/ip route
/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping

#|/ip firewall nat
/ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

#| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
/ip pool add name=default-dhcp ranges=192.168.0.100-192.168.0.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1 dns-server=192.168.0.1 comment="default configuration"

#| DNS
/ip dns set allow-remote-requests=yes
/ip dns static add name=router address=192.168.0.1

#| Now Configure DNS server so users can resolve hostnames,
#| Ex.cache-size=5000KiB
#| DNS Google = 8.8.8.8,8.8.4.4
#| DNS 3BB = 110.164.252.222,110.164.252.223
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000K max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4





แนะนำว่าก่อนทำให้ Remove config ทั้งหมดก่อนเลยโดยเป็นค่าเริ่มต้น เท่านั้น
นำ port lan cable เข้าช่อง 1 ส่วนคอมต่อเข้าช่อง 2หรือช่องไหนก็ได้ เรียกผ่าน mac address ผ่าน winbox เข้ามา
สร้าง Hotspot Setup ตามขั้นตอนไปที่ port 5 ออกมาก็ได้แล้วละครับ
เหมือนกับบทความนี้ครับ
1.19 สร้าง Hotspot ง่ายๆ โดยใช้ LoadbalanceRouter+Mikrotik

ส่วน code ผมว่าตรงนี้แปลกครับ
[code]#|/ip address
/ip address add address=192.168.1.2/24 network=192.168.10.0 broadcast=192.168.10.255 interface=ether1
เอาเป็นว่า reset แล้วทำตามด้านบนดีกว่า


2. การทำ code แบบนี้ เท่ากับเปลี่ยน ip ของ mikrotik ด้วยใช่ไหมครับ เพราะเรา remove configuration ไป เช่นในกรณีนี้จาก 192.168.88.1 มาเป็น 192.168.0.1
แล้วจาก 2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN router 1; ip 192.168.1.1
ทำไมเราเขียน code เป็น

/ip address add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1
แทนที่จะเขียนเป็น /ip address add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1


ใช่ครับ

ตัวอุปกรณ์ตอนเข้าครั้งแรก จะสร้าง ค่าคอนฟิคไว้เลยครับเพื่อง่ายและ route ออก wan ที่เราต่อเข้ามาออก port 1 ได้เลย

/ip address add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255

1. ip address add address=192.168.1.2/24 เป็นการกำหนด ip Static ขาตัวอุปกรณ์เหมือนกับเครือข่ายลูกค้าที่ต้องเอาไปรับกับ Router ที่มีอยู่ซึ่ง ถ้าดู code ต่อไป จะไปชี้ gateway 192.168.1.1 นะครับ

#|/ip route
/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping


2. network=192.168.1.0 เป็นกลุ่ม Network id

3. broadcast=192.168.1.255 เป็นกลุ่ม broadcast

4. interface=ether1 กำหนดที่ port 1



3. /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes


เราต่อ wan เเค่สายเดียว ต้องวนลูปไหมคับ เเล้ว code นี้ต้องเปลี่ยนไหมคับ


ไม่ต้องทำหรอกครับ สร้าง Hotspot setup ให้เด๋วก็สร้าง Route , magle ให้อยู่แล้วครับ



4. #| DNS 3BB = 110.164.252.222,110.164.252.223

อันนี้เกี่ยวกับเครื่อยข่ายไหมครับถ้าเปนทรูต้องเปลี่ยนไหมคับ



ทำ Hotspot เด๋วจะบอกเองครับว่าเจอ DNS อะไรอยู่ครับ หรือจะกำหนดเองก็ได้ครับ


รูปภาพ



5. การทำแบบนี้เราเสียบแลนออกจาก port 2 ของ mikrotik ทำตาม 1.1 วิธีทำ Hotspot บน MikroTik RB750G (1 Internet)ได้ปกติเลยปะครับ


ในบทความนี้
port 1 ขา WAN ออก internet
port 2 ค่า default 192.168.88.1 โดย route ออก wan 1 ให้แล้ว ต่อ port 2 นี้จะออกได้เลยครับ

port 5 hotspot



6.

#|/ip address
/ip address add address=192.168.10.2/24 network=192.168.10.0 broadcast=192.168.10.255 interface=ether1
/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment="default configuration"


การกำหนดค่านี้ ip ที่ mikrotik รับมาจาก cable router คืออะไรคับ



งง ครับยังไม่เข้าใจคำถาม

Cable route ของคุณคือ IP address อะไรครับ ???
เพราะ code ที่ให้มาเป็นการกำหนดค่าลงไปให้ตัวอุปกรณ์

โดยถ้าโค้ดเท่านั้นผมจะหมายความว่า
กำหนด 192.168.10.2 subnet 255.255.255.0 ที่ port 1
กำหนด 192.168.0.1 subnet 255.255.255.0 ที่ port 5 ชื่อเรียก default configuration



7.

#| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
/ip pool add name=default-dhcp ranges=192.168.0.100-192.168.0.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1 dns-server=192.168.0.1 comment="default configuration"


ผมต้องตั้งให้แจก ip อยู่ระหว่าง 192.168.0.100-192.168.0.200 หรอคับ


สามารถเปลีี่ยนได้ ครับ ให้ ไปตั้ง hotspot ที่ port 5 นะ
เราสามารถสร้าง หรือเปลี่ยนได้ตั้งแต่ตอนทำ hotspot setup เลยนะครับ ถ้ามาแก้ทีหลัง ค่า route หรือ ชื่อที่อ้างอิงจะมีปัญหา

รูปภาพ

รูปภาพ

รูปภาพ

รูปภาพ

อย่ามาเปลี่ยนหรือแก้ทีหลังเลยครับ



ปล ผมเสนอให้ตั้งกระทู้เกี่ยวกับการตั้ง mikrotik เมื่อเชื่อมกับกับ cable modem แบบ static ip นะครับ เพราะการตั้งแบบ DHCP Client แม้จะง่ายกว่าเเต่ทำให้ mikrotik ทำงานหนัก
คนที่ใช้อินเตอร์เน็ตแบบเคเบิ้ลก้มีเยอะขึ้นเช่นกัน


Cable router มองไปก็เป็นเหมือน Router ธรรมดาตัวนึงที่จ่าย DHCP ออกมาอยู่แล้วเหมือน router ทั้วไปโดยเราต้องทราบ
Gateway ของตัว Cable router ว่าคืออะไร
เราถึงจะสามารถไป static ip หรือจะให้รับอัตโนมัตมมาเลยก็ได้โดยเราสามารถดูได้ว่ารับ ip มาหรือเปล่าที่ เมนู ip -> address
ก็จะมองว่า port ที่ cable router มาต่อเป็นขา WAN แล้ว
ส่วน port ไหนที่ต้องการ จะ route ออก ก็ให้ไปดูขา DNS และการ route ขอ port นั้นๆ อีกที
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
vit_et07
 
โพสต์: 994
ลงทะเบียนเมื่อ: พุธ 01 ต.ค. 2008 10:30 am


ย้อนกลับไปยัง วิธีการติดตั้งและปรับแต่งอุปกรณ์ Mikrotik

ผู้ใช้งานขณะนี้

กำลังดูบอร์ดนี้: ไม่มีสมาชิกใหม่ และ บุคคลทั่วไป 4 ท่าน